Commit f7539d15 authored by Gonzalo Bayo's avatar Gonzalo Bayo

Added symbolic links to installed folder on installers

parent 9288e82f
......@@ -8,6 +8,6 @@ mkdir -p Release
cd Release
cmake .. -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=$HOME/opt/cmake-3.3.1
make install
ln -s ~/opt/modules/modules/cmake-3.3.1 ~/opt/modules/installed/cmake-3.3.1
echo "module load cmake-3.3.1" >> $HOME/.bashrc
source $HOME/.bashrc
......@@ -8,6 +8,6 @@ mkdir -p Release
cd Release
cmake .. -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=$HOME/opt/cmake-3.4.3
make install $1
ln -s ~/opt/modules/modules/cmake-3.4.3 ~/opt/modules/installed/cmake-3.4.3
echo "module load cmake-3.4.3" >> $HOME/.bashrc
source $HOME/.bashrc
......@@ -6,6 +6,6 @@ git checkout 3.1.2
mkdir -p Release && cd Release
cmake .. -DCMAKE_INSTALL_PREFIX=~/opt/eigen-3.1.2 -DCMAKE_BUILD_TYPE=Release
make install
ln -s ~/opt/modules/modules/eigen-3.1.2 ~/opt/modules/installed/eigen-3.1.2
echo "module load eigen-3.1.2" >> $HOME/.bashrc
source $HOME/.bashrc
......@@ -3,6 +3,6 @@ cd $HOME/opt
wget http://gmrv.es/~ptoharia/OpenSceneGraph-3.4.0-Qt5.5.tgz
tar zxvf OpenSceneGraph-3.4.0-Qt5.5.tgz
rm OpenSceneGraph-3.4.0-Qt5.5.tgz
ln -s ~/opt/modules/modules/OpenSceneGraph-3.4.0-Qt5.5 ~/opt/modules/installed/OpenSceneGraph-3.4.0-Qt5.5
echo "module load OpenSceneGraph-3.4.0-Qt5.5" >> $HOME/.bashrc
source $HOME/.bashrc
......@@ -8,6 +8,6 @@ make install
#Fix for CMake scripts to work
cd $HOME/opt/OpenSceneGraph-3.4.0
ln -s lib64 lib
ln -s ~/opt/modules/modules/OpenSceneGraph-3.4.0 ~/opt/modules/installed/OpenSceneGraph-3.4.0
echo "module load OpenSceneGraph-3.4.0" >> $HOME/.bashrc
source $HOME/.bashrc
......@@ -7,4 +7,4 @@ wget http://gmrv.es/~ptoharia/qt/Qt-5.10.0.tgz
tar zxvf Qt-5.10.0.tgz
rm Qt-5.10.0.tgz
ln -s ~/opt/modules/modules/Qt-5.10.0 ~/opt/modules/installed/Qt-5.10.0
echo "Please add \"module load Qt-5.10.0\" to your .bashrc to load it by default"
echo "module load Qt-5.10.0" >> $HOME/.bashrc
......@@ -3,6 +3,6 @@ cd $HOME/opt
wget http://gmrv.es/~ptoharia/qt/Qt-5.5.tgz
tar zxvf Qt-5.5.tgz
rm Qt-5.5.tgz
ln -s ~/opt/modules/modules/Qt-5.5 ~/opt/modules/installed/Qt-5.5
echo "module load Qt-5.5" >> $HOME/.bashrc
source $HOME/.bashrc
......@@ -6,5 +6,5 @@ cd /home/opt
wget http://gmrv.es/~ptoharia/qt/Qt-5.8.0.tgz
tar zxvf Qt-5.8.0.tgz
rm Qt-5.8.0.tgz
ln -s ~/opt/modules/modules/Qt-5.8.0 ~/opt/modules/installed/Qt-5.8.0
echo "Please add \"module load Qt-5.8.0\" to your .bashrc to load it by default"
......@@ -6,5 +6,5 @@ cd /home/opt
wget http://gmrv.es/~ptoharia/qt/Qt-5.9.tgz
tar zxvf Qt-5.9.tgz
rm Qt-5.9.tgz
ln -s ~/opt/modules/modules/Qt-5.9 ~/opt/modules/installed/Qt-5.9
echo "Please add \"module load Qt-5.9\" to your .bashrc to load it by default"
......@@ -6,6 +6,6 @@ tar zxvf VirtualGL-2.4.1.tar.gz
mkdir -p VirtualGL-2.4.1/Release && cd VirtualGL-2.4.1/Release
cmake .. -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=~/opt/VirtualGL-2.4.1 -DTJPEG_INCLUDE_DIR=/usr/include/ -DTJPEG_LIBRARY=/usr/lib/x86_64-linux-gnu/libturbojpeg.so.0
make -j4 install
ln -s ~/opt/modules/modules/VirtualGL-2.4.1 ~/opt/modules/installed/VirtualGL-2.4.1
echo "module load VirtualGL-2.4.1" >> $HOME/.bashrc
source $HOME/.bashrc
......@@ -20,5 +20,5 @@ make install
sed -e "s/VERSION/$d/g" $HOME/opt/modules/.coindesigner \
> $HOME/opt/modules/coindesigner-$d
ln -s ~/opt/modules/modules/coindesigner-$d ~/opt/modules/installed/coindesigner-$d
echo "module load coindesigner-$d" >> $HOME/.bashrc
......@@ -15,6 +15,6 @@ tar zxvf emacs-24.5.tar.gz
cd emacs-24.5
./configure --prefix=$HOME/opt/emacs-24.5
make install -j4
ln -s ~/opt/modules/modules/emacs-24.5 ~/opt/modules/installed/emacs-24.5
echo "module load emacs-24.5" >> $HOME/.bashrc
source $HOME/.bashrc
......@@ -16,6 +16,6 @@ tar zxvf ispc-v1.9.1-linux.tar.gz
# # Install only the executable
# mkdir $HOME/opt/ispc-${VERSION}
# cp ispc $HOME/opt/ispc-${VERSION}
ln -s ~/opt/modules/modules/ispc-${VERSION} ~/opt/modules/installed/ispc-${VERSION}
echo "module load ispc-"${VERSION} >> $HOME/.bashrc
source $HOME/.bashrc
......@@ -7,6 +7,6 @@ cd libQGLViewer-2.6.3
qmake
make -j4
INSTALL_ROOT=~/opt/libQGLViewer-2.6.3 make install
ln -s ~/opt/modules/modules/libQGLViewer-2.6.3 ~/opt/modules/installed/libQGLViewer-2.6.3
echo "module load libQGLViewer-2.6.3" >> $HOME/.bashrc
source $HOME/.bashrc
\ No newline at end of file
source $HOME/.bashrc
......@@ -8,4 +8,5 @@ git checkout v${NINJA_VERSION}
mkdir -p $HOME/opt/ninja-${NINJA_VERSION}
cp ninja $HOME/opt/ninja-${NINJA_VERSION}
echo "module load ninja-${NINJA_VERSION}" >> $HOME/.bashrc
ln -s ~/opt/modules/modules/ninja-${NINJA_VERSION} ~/opt/modules/installed/ninja-${NINJA_VERSION}
source $HOME/.bashrc
......@@ -9,5 +9,6 @@ cmake ../cmake/ -DCMAKE_BUILD_TYPE=Release -Dprotobuf_BUILD_TESTS=OFF \
-DCMAKE_INSTALL_PREFIX=~/opt/protobuf-3.1.0 \
-DCMAKE_CXX_FLAGS="-fPIC"
make install -j4
ln -s ~/opt/modules/modules/protobuf-3.1.0 ~/opt/modules/installed/protobuf-3.1.0
echo "module load protobuf-3.1.0" >> $HOME/.bashrc
source $HOME/.bashrc
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment